[solved] 0.4.9.9.3 amd64 not starting on Debian 9.0 "Stretch"

New Debian stable “Stretch” was released some days ago.

I dist-upgraded from Jessie to Stretch, and now Bitsquare 0.4.9.9.3 does not run anymore.

Error message is ‘Segmentation fault’.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 9.0 (stretch)
Release:        9.0
Codename:       stretch
$ uname -a
Linux bitcoind 4.9.0-3-amd64 #1 SMP Debian 4.9.30-2+deb9u1 (2017-06-18) x86_64 GNU/Linux

$ /opt/Bitsquare/Bitsquare 
Segmentation fault
1 Like

Hm… no idea. maybe try to reinstall it.

I will add that JVMUserOptions to the next release which will get out soon.

I had the same problem with bisq not starting after upgrading to Debian 9.0 Stretch. I’d copied my data directory to my old netbook (which I hadn’t upgraded from Debian Jessie) and bisq worked fine (except for being painfully slow, but that’s due to the dinky Atom processor and only 1 GB of non-upgradable RAM soddered to the motherrboard on that little Nokia Booklet 3G), so I was able to finish my active trade.

I tried @anon10998290’s solution, and it works perfectly for me. So I agree that including that fix in the next bisq upgrade would help folks using Debian Stretch and its derivatives like Ubuntu and Linux Mint.

The new release has that VM option ans hopefully that Kernel issue is solved by that.

Ah good then the jre option is sufficient.